On Tue, Apr 13, 2010 at 4:27 PM, Jason Fawcett <li...@ruby-forum.com> wrote:
> Hi all,
>  I'm very new to Ruby, and I'm trying to learn Ruby on Rails.  I got a
> book on the subject, and I've installed everything according to the
> directions, but I can't get the Mongrel server to work.  I'm using the
> RadRails plugin with Aptana Studio, I've started a new project, and
> everything seems to be setup fine, but whenever I try to start the
> server, I get the following:
> C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:156:in
> `require': 126: The specified module could not be found.   -
> C:/Ruby19/lib/ruby/gems/1.9.1/gems/mongrel-1.1.5-x86-mingw32/lib/http11.so
> (LoadError)
>  from
> C:/Ruby19/lib/ruby/gems/1.9.1/gems/activesupport-2.3.4/lib/active_support/dependencies.rb:156:in
> `block in require'
>  from

The gem you have installed has been compiled for Ruby 1.8, not Ruby 1.9

You need a gem that is compatible with Ruby 1.9

At this time, I would recommend you install the pre-release version of the gem:

gem install mongrel --pre

Which includes binaries for 1.9

Luis Lavena
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry
Mongrel-users mailing list

Reply via email to