Here are my notes:


upgrade ruby gems (gem update --system)
verify that the currently installed version of mongrel is 1.1.5 or later and
if it isn't:
uninstall mongrel (gem uninstall mongrel)
install mongrel (gem install mongrel)
verify that the currently installed version of mongrel_service is 0.4.beta3
or later and if it isn't:
uninstall mongrel_service (gem uninstall mongrel_service)
install mongrel_service (gem install mongrel_service)
use gem list and verify that the mongrel_service installed is 0.4 or later.
If it isn't, you need to take these extra steps:
uninstall mongrel_service (gem uninstall mongrel_service)
install mongrel_service 0.4.beta3 (gem install mongrel_service --pre)
verify that the correct mongrel service has been installed by typing
mongrel_service at the dos prompt. Which should produce output like:
Mongrel Windows Service, version 0.4.beta2
(c) 2006-2010 The Mongrel development team.

mongrel_service is not designed to run form commandline,
please use mongrel_rails service:: commands to create a win32 service.

If the version is less than 0.4.beta2, you need to manually copy the new
mongrel_service.exe. On my system, Ruby is installed in C:\Ruby and I would
have to copy the file:
to folder:

Finally, navigate to the folder holding the RoR application and invoke these
commands to uninstall/install the service:

mongrel_rails service::remove  -N APALSvc

mongrel_rails service::install -N APALSvc -D "AutoPallet/AutoLoader Service"
-c "D:/Development/APAL6/APALUI" -e production -p 3035 --log log/mongrel.log


> -----Original Message-----
> From: 
> [] On Behalf Of Edison Ting
> Sent: Tuesday, 1 February 2011 5:44 p.m.
> To:
> Subject: Re: [Mongrel] Mongrel service
> Hi Luis,
> I am trying to set up mongrel service on windows XP using 
> Rails 2.3.2 and mongrel 1.1.5.
> I manage to run my app as windows services but I am unable to 
> go further with option such as -l, -P, or -C work.
> I tried -l and give full log file path but there's no log file.
> I tried -P but I don't see a pid file on the folder I specified.
> I tried to do -p 4100+3 but unable to have the service run 
> for port 4100, 4101 and 4102.
> I also would like to use -C so that I can use a yml config 
> file but I did not see any documentation of how to configure it.
> I am familiar with mongrel_cluster in linux but I wish I 
> could get this working on windows machine as well.
> I've read some of your post and indeed it helped me to get this far.
> Please give me some light?
> --
> Posted via
> _______________________________________________
> Mongrel-users mailing list

Mongrel-users mailing list

Reply via email to