Hello Alex,

I'm not building from git-master or git; I am using monolite.  I think I
mentioned this earlier…if not, apologies for leaving out important info.

I've gotten past the SIGSEGV I mentioned earlier by editing threads.c (see
https://github.com/mono/mono/commit/1c9e34cce5e53ec5126d546a3014bc1493425219).


I've run into a new error that seems to occur in sgen. I'm going to try
building without it enabled.

Cyd

On Oct 12, 2016 1:16 PM, "Alexander Köplinger" <alk...@microsoft.com> wrote:

> If you don’t have a working Mono installed on your system for
> bootstrapping then the recommended way is to use monolite if you build from
> git master: https://github.com/mono/mono#if-you-dont-have-a-
> working-mono-installation
>
> - Alex
>
> On 12 Oct 2016, at 20:02, Cyd Haselton <chasel...@gmail.com> wrote:
>
> Hello Ludovic,
>
> Would the missing 'last' field cause the SIGSEGV?
>
> Cyd
>
> On Oct 12, 2016 12:18 PM, "Cyd Haselton" <chasel...@gmail.com> wrote:
> >
> > Full output of './mono/mini/mono -V' here: http://pastebin.com/xZw3qhVD
> <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fpastebin.com%2FxZw3qhVD&data=01%7C01%7Calkpli%40microsoft.com%7C4f1712aba12141771e4008d3f2c9fd2e%7C72f988bf86f141af91ab2d7cd011db47%7C1&sdata=rL8nuhHORHneIWc3OgllqTo2iB7RdN8P5YdOU2jNPpo%3D&reserved=0>
> >
> >
> > On Oct 12, 2016 12:12 PM, "Cyd Haselton" <chasel...@gmail.com> wrote:
> >>
> >> Since I don't have a working mcs installed, I'm using the snapshots
> available from the download site here: http://download.mono-project.
> com/sources/mono/
> <https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fdownload.mono-project.com%2Fsources%2Fmono%2F&data=01%7C01%7Calkpli%40microsoft.com%7C4f1712aba12141771e4008d3f2c9fd2e%7C72f988bf86f141af91ab2d7cd011db47%7C1&sdata=T%2BA5GezSev7nlwMowcNsMGaftco014weAy31yrfIRbM%3D&reserved=0>
> >>
> >> Here's the output of ./mono/mini/mono -V from my build tree:
> >>
> >> ./mono/mini/mono -V
>
> >> Mono JIT compiler version 4.7.0 (Nightly 4.7.0.593/4e441ec
> >>
> >>
> >> On Oct 11, 2016 10:06 AM, "Ludovic Henry" <luhe...@microsoft.com>
> wrote:
> >>>
> >>> Hi Cyd,
> >>>
> >>>
> >>>
> >>> Which mono commit are you based on? It seems like the managed
> System.Threading.InternalThread is missing the “last” field.
> >>>
> >>>
> >>>
> >>> Thank you,
> >>>
> >>> Ludovic
> >>>
> >>>
> >>>
> _______________________________________________
> Mono-devel-list mailing list
> Mono-devel-list@lists.dot.net
> https://na01.safelinks.protection.outlook.com/?url=
> http%3A%2F%2Flists.dot.net%2Fmailman%2Flistinfo%2Fmono-
> devel-list&data=01%7C01%7Calkpli%40microsoft.com%
> 7C4f1712aba12141771e4008d3f2c9fd2e%7C72f988bf86f141af91ab2d7cd011
> db47%7C1&sdata=b9Lybet0SXWu5pvvxt7qTTZx1Azx7BMcrE%2BmpZbnzq0%3D&reserved=0
>
>
>
_______________________________________________
Mono-devel-list mailing list
Mono-devel-list@lists.dot.net
http://lists.dot.net/mailman/listinfo/mono-devel-list

Reply via email to