> On 18 Oct 2016, at 15:19, Eric Blake <ebl...@redhat.com> wrote:
> 
> Initial testing: broken before my patches:
> 
> checking for GnuTLS... configure: error: Package requirements (gnutls >=
> 3.3.0) were not met:
> 
> Requested 'gnutls >= 3.3.0' but version of GnuTLS is 2.8.5
> 
> You'll want to make the new TLS code conditional, and merely disable TLS
> rather than fail the entire build if you don't have a new enough library
> to rely on.  I might be able to develop that patch too...

I don't think we should require gnutls >= 3.3.0

My patches (for both the server and client) worked with an older versions
of gnutls deliberately (certainly whatever ships with Ubuntu 14.04, which
I think is 2.12.23).

Is there any reason to depend on such a new version of gnutls? I
seem to remember that one tiny bit of set up took slightly more
calls on old versions.

My branch is at:
  https://github.com/abligh/nbd/tree/add-tls-support

if you want to nick the TLS code (including autotools etc support)

--
Alex Bligh




Attachment: signature.asc
Description: Message signed with OpenPGP using GPGMail

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most 
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Nbd-general mailing list
Nbd-general@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/nbd-general

Reply via email to