Thomas A. Schmitz wrote:
On Nov 20, 2009, at 1:17 PM, Wolfgang Schuster wrote:

Hi Hans, all,

the two latest betas have trouble loading fonts from my own typescripts. All 
errors point to the same line in font-syn.lua. I don't have a minimal example 
yet, but here's a minimal command line that triggers the error on my box:

mtxrun --script fonts --list --pattern="*gentium*"
...text/tex/texmf-context/tex/context/base/font-syn.lua:706: bad argument #1 to 
'next' (table expected, got nil)

Any pointers?
1. delete the luatex cache
2. luatools --selfupdate
  mtxrun --selfupdate
3. luatools --generate

Taco, Wolfgang,

thanks for your replies. Wolfgang: that doesn't change anything here. Taco: after applying this patch, a luatex-cache hangs at
!load otf       : loading: 
/Users/tas/texmf/fonts/truetype/greek/gentium/GenAR102.TTF (hash: 
genar102-gentium)

So it looks like the font loading mechanism has some deeper problems. The same 
binary works as exoected with an older version of ConTeXt, so it doesn't appear 
to be a luatex problem.

do you have a small test file?


-----------------------------------------------------------------
                                          Hans Hagen | PRAGMA ADE
              Ridderstraat 27 | 8061 GH Hasselt | The Netherlands
     tel: 038 477 53 69 | fax: 038 477 53 74 | www.pragma-ade.com
                                             | www.pragma-pod.nl
-----------------------------------------------------------------
___________________________________________________________________________________
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki     : http://contextgarden.net
___________________________________________________________________________________

Reply via email to