Hi all, Hans,

something is not working with our simpleslides module and the latest beta. The following example (from our documentation) is not quite minimal, but it shows the problem:

\unprotect
\def\setupTitle%
  {\dosingleargument\dosetupTitle}

\def\dosetupTitle%
  {\setvariables[simpleslides:title]}

\def\simpleslidestitleparameter%
  {\getvariable{simpleslides:title}}

\def\simpleslidestitlecomponent#1%
  {\doattributes{\??vars:simpleslides:title:}{#1\c!style}{#1\c!color}
          {\getvariable{simpleslides:title}{#1}}}

\define\placeTitle
  {\dostartattributes{\??vars:simpleslides:title:}\c!style\c!color
    \simpleslidestitlecomponent\c!title
   \dostopattributes}

\protect

\setupTitle
  [ title={Title of the presentation},
  ]

\starttext
\placeTitle

Write whatever you want.

Continue writing.

\stoptext

Instead of picking up and typesetting the content of the variable "title," it typesets the word "title." Beta from Nov. 29 works normally. Let me know if you can use this example or if you need something else (Aditya is away at a conference, he may be able to come up with a better example).

All best

Thomas
___________________________________________________________________________________
If your question is of interest to others as well, please add an entry to the 
Wiki!

maillist : ntg-context@ntg.nl / http://www.ntg.nl/mailman/listinfo/ntg-context
webpage  : http://www.pragma-ade.nl / http://tex.aanhet.net
archive  : http://foundry.supelec.fr/projects/contextrev/
wiki     : http://contextgarden.net
___________________________________________________________________________________

Reply via email to