Hi,

On Tue, Nov 20, 2012 at 8:01 PM, Stefan Guggisberg
<stefan.guggisb...@gmail.com> wrote:
> - returning an :id and/or :hash should be optional, i.e. we shouldn't
>   require an implementation to return an :id or :hash for every path

Exactly.

> - i suggest we prefix the id/path getNodes parameter value with ':id:'
> and ':hash:'

I'd leave the format up to the MK implementation to decide, with
oak-core just passing whatever the MK gave as the ":id" or ":hash"
attribute of a child object. For example, an MK that selects to use
":id:" and ":hash:" prefixes for such values, would work something
like this:

    getNodes("/") => { "a": { ":id": ":id:x" } }
    getNodes(":id:x") => { "b": { :id": ":id:y" } }
    getNodes(":id:y") => { "c": { :id": ":id:z"} }
    getNodes(":id:z") => {}

> - do you have a proposal for the suggested MicroKernel API (java doc)
>   changes?

I'll have one to share shortly...

BR,

Jukka Zitting

Reply via email to