Recent changes to my Thunderbird email client apparently has prevented my recent request for help with ooSQLite to not be sent to the full mailing list.

So here is a repeat of my original request for help...

I am trying to use ooSQLite with ooRexx V5.0
I had being using it successfully with ooRexx v4.2 ever since it was first released in 2014 up until I installed ooRexx 5.0..

Due to a LINUX operating system upgrade failure (UBUNTU 20.04.10 LTS to UBUNTU 21.04.10 LTS) in August 2022, and the failure of UBUNTU in fixing Display Manager problems, I have had to switch to using Linux Mint 21. Because the UBUNTU upgrade also destroyed the Disk drives used by my backup system, I also lost my entire archive of ooREXX programs.

so the problem that I am having with ooSQLite might be a simple installation issue, or possibly an oversight when ooRexx 5.0 was initally released in December of 2022.

Under rexx 5.0 ooSQLite  fails everytime with the following message

*bill@wb4alm-07:~$ pccg-roster
    57 *-* ::attribute null get class external "LIBRARY oosqlite oosql_getNull_atr_cls"
    40 *-* ::requires 'ooSQLite.cls'
Error 98 running /usr/local/bin/ooSQLite.cls line 57: Execution error.
Error 98.903:  Unable to load library "oosqlite".

I had noticed that the windows version of ooSQLite has been upgraded but that the LINUX version has not.

Marc Remes, noticed that there was a single update for a standalone copy of, so he advised me to download
and install it.

I have done so, but that does not change anything. Was ooSQLite.cls suppossed to also have been updated with Rexx 5.0?

Marc, also suggested that LD_LIBRARY_PATH be updated, but I don't think this is required, as it has not been in the past, and other "add on's" like FTP work.

The replies below, will show that the three modules required for ooSQLite are in the PATH, which is what the documentation says is needed. (All ooREXX 5.0 stuff is in  "/usr/local/bil", which is where the "installation" packages put them.)

/s/ Bill Turner, wb4alm

On 5/31/23 04:46, Bill Turner, WB4ALM wrote:


I do not understand why LD_LIBRARY_PATH is required. I have never had to set it before.

bill@wb4alm-07:~$ *which rexx*
bill@wb4alm-07:~$ *rexx -v*
Open Object Rexx Version 5.0.0 r12535
Build date: Dec  1 2022
Addressing mode: 64
Copyright (c) 1995, 2004 IBM Corporation. All rights reserved.
Copyright (c) 2005-2022 Rexx Language Association. All rights reserved.
This program and the accompanying materials are made available under the terms of the Common Public License v1.0 which accompanies this distribution or at
bill@wb4alm-07:~$ *which*
bill@wb4alm-07:~$ *which oosqlite3*
bill@wb4alm-07:~$ *echo $LD_LIBRARY_PATH**
bill@wb4alm-07:~$ *echo $PATH*

As you can see LD_LIBRARY_PATH is empty, but the three modules for ooSQLite are in "/usr/local/bin" which is the third library in $PATH.

I quote the ooSQLite-ReadMe.txt
/To use ooSQLite in your ooRexx programs simply add this requires statement//
//  to the program://
//  ::requires 'ooSQLite.cls'//
//  and ensure that the files ooSQLite.cls and ooSqlite.dll (Windows) or//
// (unix-like systems) are somewhere in the path on your system./

The three modules for ooSQLite are in "/usr/local/bin" which is the third library in $PATH

As listed before the following modules are in /usr/local/bin

along with

/s/ Bill Turner, wb4alm

On 5/30/23 07:59, Marc Remes wrote:
Hi Bill,

you did set LD_LIBRARY_PATH to the directory where the .so resides, did you?


On 5/30/23 13:47, Bill Turner, WB4ALM wrote:
Thank you Marc, I did not see that.  I have downloaded and installed it but still get the same error:

bill@wb4alm-07:~$ pccg-roster
     57 *-* ::attribute null get class external "LIBRARY oosqlite oosql_getNull_atr_cls"
     39 *-* ::requires 'ooSQLite.cls'
Error 98 running /usr/local/bin/ooSQLite.cls line 57: Execution error.
Error 98.903:  Unable to load library "oosqlite"

Line 57 in ooSQLite.cls is:
::attribute null get class external "LIBRARY oosqlite oosql_getNull_atr_cls"

/s/ Bill Turner, wb4alm

On 5/30/23 06:57, Marc Remes wrote:
FWIW, there is a more recent version of dated 2023-01-05 to be found on sourceforge.

That might help.


Oorexx-devel mailing list
Oorexx-devel mailing list

Reply via email to