The library definitely has to be the same. We had someone that was
occasionally putting an extra space in front of their policy name so the
856 did not display as expected. Or the reocrd search as expected.

One thing to remember about suppressing the |3 is that it can be used to
specify which part of the resource the 856 applies to, and may not indicate
the entire resource. In cases where there are multiple 856s in a record, it
can be used to identify the specific material linked in the URI. For
example, a record might have an 856 for a TOC, one for an author bio,
another for the abstract, and one for the resource itself, all of which
would be identified in the |3. If just the link displays, there might not
be enough obvious information to distinguish them.

I personally prefer a text to identify the link rather than the link
itself. Part of the problem with the |3 is that it is so bare in some
instances, like the first record. I think Museum Handbook would be much
more useful than pts 1-3, but that may be more appropriate for a |y than a
|3. You can customize the 856 as you are adding the  |9 so that it displays
as you want it to in the OPAC

Elaine



J. Elaine Hardy
PINES & Collaborative Projects Manager
Georgia Public Library Service/PINES
1800 Century Place, Ste. 150
Atlanta, GA 30045

404.235.7128 Office
404.548.4241 Cell
404.235.7201 FAX

On Tue, Jul 10, 2018 at 9:08 AM, Kathy Lussier <kluss...@masslnc.org> wrote:

> Hi Valerie,
>
> In the last link you shared, I noticed that the subfield 9 contains the
> value Lummi, instead of LUMMI, which is what was used in the original
> record you shared. I think Lummi may need to be added in all caps for the
> catalog to show the link. The link will only display if the search library
> either matches the org unit in the subfield 9 or is a child of that org
> unit. Without entering the Lummi in all caps, the system probably isn't
> able to identify which org unit is listed there.
>
> For the first record you sent, the link is displaying as expected since
> it's pulling the label from the subfield 3 and is pulling the URL from the
> subfield u. Were you hoping that it would display the text of the link?
> That may be doable with a tweak to the template code, but I haven't taken a
> look at it to see what would need to be done. I can't remember how the 856
> fields displayed back in 2.1 and don't know what changes may have been made
> since then.
>
> I hope this helps!
> Kathy
>
> --
> Kathy Lussier
> Project Coordinator
> Massachusetts Library Network Cooperative
> (508) 343-0128kluss...@masslnc.org
>
>
> On Mon, Jul 9, 2018 at 6:14 PM, Valerie McBeth <vmcb...@nwic.edu> wrote:
>
>> So I added a subfield 3 to a different record:
>> http://opac.nwic.edu/eg/opac/record/37700?query=quiet%20cris
>> is;qtype=title;locg=1;detail_record_view=0;expand=marchtml#marchtml
>>
>> Restarted Evergreen and the link didn’t show up in the display. But that
>> record has a URL in the 538 field, isn’t a link, but when copied and pasted
>> into the browser gets there. That address isn’t the PURL, which does show
>> in the MARC record, which also works when copied and pasted.
>>
>> Other thoughts?
>>
>> Thanks,
>>
>> Valerie
>>
>>
>>
>> *From:* Open-ils-general <open-ils-general-bounces@list
>> .georgialibraries.org> *On Behalf Of *Elaine Hardy
>> *Sent:* Monday, July 09, 2018 12:23 PM
>>
>> *To:* Evergreen Discussion Group <open-ils-general@list.georgia
>> libraries.org>
>> *Subject:* Re: [OPEN-ILS-GENERAL] 856 subfield u
>>
>>
>>
>> The |3 replaces the |u in the display -- see
>> https://www.oclc.org/bibformats/en/controlsubfields.html#subfield3
>>
>>
>>
>>
>>
>>
>> J. Elaine Hardy
>>
>> PINES & Collaborative Projects Manager
>>
>> Georgia Public Library Service/PINES
>>
>> 1800 Century Place, Ste. 150
>> <https://maps.google.com/?q=1800+Century+Place,+Ste.+150+%0D%0A+%0D%0A+Atlanta,+GA+30045&entry=gmail&source=g>
>>
>> Atlanta, GA 30045
>> <https://maps.google.com/?q=1800+Century+Place,+Ste.+150+%0D%0A+%0D%0A+Atlanta,+GA+30045&entry=gmail&source=g>
>>
>> 404.235.7128 Office
>>
>> 404.548.4241 Cell
>>
>> 404.235.7201 FAX
>>
>>
>>
>> On Mon, Jul 9, 2018 at 3:08 PM, Valerie McBeth <vmcb...@nwic.edu> wrote:
>>
>> Elaine,
>>
>> The indicators are 4 and 0.
>>
>> Kathy,
>>
>> Here’s a link to one record; http://opac.nwic.edu/eg/opac/r
>> ecord/37612?query=Museum%20handbook;qtype=title;locg=1;detai
>> l_record_view=0
>>
>> Interestingly, this record has an 856 subfield 3, which does function as
>> a link, and I can’t figure that out, and the other ebook records I’ve
>> sampled don’t have that.
>>
>> Thank you both,
>>
>> Valerie
>>
>>
>>
>> *From:* Open-ils-general <open-ils-general-bounces@list
>> .georgialibraries.org> *On Behalf Of *Elaine Hardy
>> *Sent:* Monday, July 09, 2018 12:00 PM
>> *To:* Evergreen Discussion Group <open-ils-general@list.georgia
>> libraries.org>
>> *Subject:* Re: [OPEN-ILS-GENERAL] 856 subfield u
>>
>>
>>
>> Check the indicators on the 856. If they aren't 40, the subfield might
>> not show up
>>
>>
>>
>>
>>
>>
>> J. Elaine Hardy
>>
>> PINES & Collaborative Projects Manager
>>
>> Georgia Public Library Service/PINES
>>
>> 1800 Century Place, Ste. 150
>> <https://maps.google.com/?q=1800+Century+Place,+Ste.+150+%0D%0A+%0D%0A+Atlanta,+GA+30045&entry=gmail&source=g>
>>
>> Atlanta, GA 30045
>> <https://maps.google.com/?q=1800+Century+Place,+Ste.+150+%0D%0A+%0D%0A+Atlanta,+GA+30045&entry=gmail&source=g>
>>
>> 404.235.7128 Office
>>
>> 404.548.4241 Cell
>>
>> 404.235.7201 FAX
>>
>>
>>
>> On Mon, Jul 9, 2018 at 2:56 PM, Kathy Lussier <kluss...@masslnc.org>
>> wrote:
>>
>> Hi Valerie,
>>
>>
>>
>> Would you be able to send a link to an example record?
>>
>>
>>
>> Thanks!
>>
>> Kathy
>>
>>
>> --
>>
>> Kathy Lussier
>>
>> Project Coordinator
>>
>> Massachusetts Library Network Cooperative
>>
>> (508) 343-0128
>>
>> kluss...@masslnc.org
>>
>>
>>
>> On Mon, Jul 9, 2018 at 2:23 PM, Valerie McBeth <vmcb...@nwic.edu> wrote:
>>
>> Hello,
>>
>> We recently moved from 2.1 to 3.0.4. In 2.1, when we retrieved a record
>> for an ebook, the field 856 subfield u content showed up as a functional
>> link. Now it doesn’t show up on the on the initial page, it does show up in
>> the MARC view, but doesn’t function as a link. Any thoughts? Remedies?
>>
>> Thanks,
>>
>> Valerie
>>
>>
>>
>>
>>
>>
>>
>
>

Reply via email to