Ben Lake wrote:
> Hello all,
> 
> Before I ask anything I'd like to say thank you to all the devs. I 
> appreciate the existence of your project and your hard work!
> 
> Now I've got a little situation which should hopefully be chalked up to 
> my newb status with open-iscsi.
> 
> Per the snippet below I can't seem to manually login directly to a 
> single target. Every time I try I get "iscsiadm: no records found!". 
> Whether I use the target name, portal, or both. As you can see I have a 
> discovery entry for the portal, and I have a target entry in the node 
> table. The only way I can login to this target is with a blanket node 
> login. It does work. The other interesting bit is when I set the config 
> to auto connect to all targets on startup, that did _not_ work. So 
> apparently the auto connect doesn't use the blanket node login mechanism 
> or some such. Any thoughts or flames are appreciated :P
> 
> Thanks again!
> 
> --- snip ---
> [EMAIL PROTECTED]:~$ sudo iscsiadm -m discovery
> 10.0.0.11:3260 via sendtargets
> [EMAIL PROTECTED]:~$ sudo iscsiadm -m node
> 10.0.0.11:3260,1 ign.2002-07.com.archose:3t.r5.0

Normally the name of the target starts with "iqn". A "Q" instead of a 
"G" like above. Below you use a "Q", which is probably why it is not 
working. Sometimes you also drop parts of the name.

> [EMAIL PROTECTED]:~$ sudo iscsiadm -m node -T 
> iqn.2002-07.com.archose:3t.r5.0 -p 10.0.0.11:3260 -l

If the target has a "G" in the node db, then you need to pass it a "G" 
here. This has a "Q" in the iqn.

> iscsiadm: no records found!
> [EMAIL PROTECTED]:~$ sudo iscsiadm -m node -T iqn.2002-07.com.archose -p 

This one will not work because it is misspelled. It is missing the end 
part ":3t.r5.0", and you need to use a "G" like in the node db.

> 10.0.0.11:3260 -l
> iscsiadm: no records found!
> [EMAIL PROTECTED]:~$ sudo iscsiadm -m discovery -P 1
> SENDTARGETS:
> DiscoveryAddress: 10.0.0.11,3260
>     Target: ign.2002-07.com.archose:3t.r5.0
>         Portal: 10.0.0.11:3260,1
>            Iface Name: default
> iSNS:
> No targets found.
> STATIC:
> No targets found.
> [EMAIL PROTECTED]:~$ sudo iscsiadm -m session -P 1
> iscsiadm: No active sessions.
> [EMAIL PROTECTED]:~$ sudo iscsiadm -m node -T iqn.2002-07.com.archose -l

This one is just mispelled. No ending.

> iscsiadm: no records found!
> [EMAIL PROTECTED]:~$ sudo iscsiadm -m node -l
> Login session [iface: default, target: ign.2002-07.com.archose:3t.r5.0, 

See this has a "G". So you need to use a "G" or fix it on the target so 
it is spelled like how you want.


> portal: 10.0.0.11,3260]


For the automatic login, how are you settting the automatic login? By 
setting it in /etc/iscsi/iscsid.conf then running discovery or did you 
run the iscsiadm in update mode to set the setting? If the latter maybe 
you had it mispelled so it did not get picked up.

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"open-iscsi" group.
To post to this group, send email to open-iscsi@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at http://groups.google.com/group/open-iscsi
-~----------~----~----~----~------~----~------~--~---

Reply via email to