That didn't help. This is still plaguing me, but now it can happen when debugging a remote process.

Anyone have any ideas on what can be causing this?


On Dec 31, 2006, at 10:59 AM, Patrick Linskey wrote:

Note that the datacache is enabled by default. To turn off, set
openjpa.DataCache to false.


Patrick Linskey
BEA Systems, Inc.

______________________________________________________________________ _ Notice: This email message, together with any attachments, may contain information of BEA Systems, Inc., its subsidiaries and affiliated entities, that may be confidential, proprietary, copyrighted and/or legally privileged, and is intended solely for the use of the individual or entity named in this message. If you are not the intended recipient, and have received this message in error, please immediately return this
by email and then delete it.

-----Original Message-----
From: Marc Prud'hommeaux [mailto:[EMAIL PROTECTED] On
Behalf Of Marc Prud'hommeaux
Sent: Sunday, December 31, 2006 9:46 AM
Subject: Re: Debugger Not Working?


Do you have the data cache enabled? If so, can you disable it
and see
if it changes anything? I'm still guessing that this might be due to
dynamic class generation, which the data cache sometimes does.

If you enable verbose logging (e.g., by setting the property
"openjpa.Log: DefaultLevel=TRACE"), what are the last few log
messages you see before the hang?

On Dec 31, 2006, at 12:28 PM, Dain Sundstrom wrote:

On Dec 31, 2006, at 12:04 AM, Marc Prud'hommeaux wrote:

I've never experienced this problem, but as a guess, are you
running with dynamic enhancement (using the "-javaagent"
flag)? If
so, what happens if you enhance manually, and then run
without the
agent flag?

Currently, I am, but I can recreate the problem without it,
it just
takes a lot longer.  Actually, it seems be related to the
amount of
code executed.  If I run the Agent and it enhances, that is a lot
of code executed and the problem happens quickly.  If I run derby
instead of HSQLDB, it happens quickly.  It is very strange.

Also, you could always try running "javastack" on a
process (found
using "jps") from a console and see if you get a stack trace from

I'll try that.


Reply via email to