Many thanks for the hints!

This worked:
#boot from installation media
#sudo zpool import rpool
#sudo zpool export rpool

Note: i didn't have to specify -d /dev/dsk or the like, the device name was automatically changed.

Over night i had an idea which might have solved this without reboot:
-define a partition on a spare drive with the exact same size as the rpool partition
-add this new device as a mirror device to the rpool
-wait for resilver complete
-detach the original device
-"some magic" to clear the zpool/zfs info on the original device
-re-add the 'cleaned' original device
-wait for resilver complete
-detach the temporary used device

Any thoughts on this?
if this were a good idea, can someone give the missing command line details for the next person who needs this?

Greetings from Germany,

On 04/14/18 08:43 AM, Nikola M wrote:
On 04/13/18 11:27 PM, Till Wegmüller wrote:
Hi Stephan

Is this a Linux dualboot machine?

Linux has the tendency to overwrite the device section of a zpool when
importing. /dev/sdc looks like a linux name.

If so you may have killed that zpool by importing it from linux.
AFAIK there is currently no good solution to fix the device name entry.

Except from, booting from Live media (DVD,USB) , importing pool and exporting pool and reboot?

Also be sure to stick to either slices or partitions p1 != s1 in your
One is the traditional Solaris Slice layout of the disk the other the
Partitions in DOS style. They do not mix at all.

It means there is a difference if partitions are created under illumos/Solaris and Linux. up to 4 'Slices' can fit insite standard(MBR) partition and when creating ZFS partition from OI, it creates one slice inside partition for ZFS.
And that is not the same as having ZFS on top of partition.
So it is better to create partition aether during illumos install (and not before install) because of that difference.

I had a problem with reinstalling illumos loader while retaining MBR partition, With ZFS on it without slice on partition. Would need to re-check if that works now, but it is always better to create ZFS partition with illumos fdisk or OI Install process.

And also there is the question weather Hard disk cache is turned on if ZFS uses partition and not the whole drive. Previoiusly, Hard disk caching used to be turned OFF if ZFS is on partition and not on the whole drive, for UFS compatibility. Don't know how it is now nor how to explicitlycheck/turn ON Hard disk caching if ZFS pool uses partition on drive.

openindiana-discuss mailing list

openindiana-discuss mailing list

Reply via email to