Hello Timur,

I have one question, so I am testing rally boot and delete scenario, it seems 
to work fine when tenant is 1 and user is 1. Although if I change tenant to 2 
and users 2, I see below error. Any idea why this can happen ?


2014-09-03 10:51:18.138 17441 CRITICAL rally [-] ServiceUnavailable: Unable to 
create the network. No tenant network is available for allocation.

cat boot-runcommand-delete.json


    "VMTasks.boot_runcommand_delete": [


            "args": {

                "flavor": {

                    "name": "m1.small"


                "image": {

                    "name": "Ubuntu Server 14.04"


                "fixed_network": "net04",

                "floating_network": "net04_ext",

                "use_floatingip": true,

                "script": "doc/samples/tasks/support/instance_dd_test.sh",

                "interpreter": "/bin/sh",

                "username": "ubuntu"


            "runner": {

                "type": "constant",

                "times": 10,

                "concurrency": 2


            "context": {

                "neutron_network": {

                    "network_cidr": "10.%s.0.0/16",


                "users": {

                    "tenants": 2, ==> Works with this value being 1

                    "users_per_tenant": 2








From: Timur Nurlygayanov 
Date: Friday, August 29, 2014 at 1:54 PM
To: "OpenStack Development Mailing List (not for usage questions)" 
Cc: Harshil Shah <harss...@cisco.com<mailto:harss...@cisco.com>>
Subject: Re: [openstack-dev] Rally scenario Issue

Hi Ajay,

looks like you need to use NeutronContext feature to configure Neutron Networks 
during the benchmarks execution.
We now working on merge of two different comits with NeutronContext 
https://review.openstack.org/#/c/96300  and 

could you please apply commit https://review.openstack.org/#/c/96300 and run 
your benchmarks? Neutron Network with subnetworks and routers will be 
automatically created for each created tenant and you should have the ability 
to connect to VMs. Please, note, that you should add the following part to your 
task JSON to enable Neutron context:
"context": {
    "neutron_network": {
        "network_cidr": "10.%s.0.0/16",

Hope this will help.

On Fri, Aug 29, 2014 at 11:42 PM, Ajay Kalambur (akalambu) 
<akala...@cisco.com<mailto:akala...@cisco.com>> wrote:
I am trying to run the Rally scenario boot-runcommand-delete. This scenario has 
the following code
 def boot_runcommand_delete(self, image, flavor,
                               script, interpreter, username,
                               ip_version=4, port=22,
                               use_floatingip=True, **kwargs):
  server = None
        floating_ip = None
            print "fixed network:%s floating network:%s" 
            server = self._boot_server(
                image, flavor, key_name='rally_ssh_key', **kwargs)

            self.check_network(server, fixed_network)

The question I have is the instance is created with a call to boot_server but 
no networks are attached to this server instance. Next step it goes and checks 
if the fixed network is attached to the instance and sure enough it fails
At the step highlighted in bold. Also I cannot see this failure unless I run 
rally with –v –d object. So it actually reports benchmark scenario numbers in a 
table with no errors when I run with
rally task start boot-and-delete.json

And reports results. First what am I missing in this case. Thing is I am using 
neutron not nova-network
Second when most of the steps in the scenario failed like attaching to network, 
ssh and run command why bother reporting the results


OpenStack-dev mailing list


QA Engineer
OpenStack Projects
Mirantis Inc

OpenStack-dev mailing list

Reply via email to