On 15 November 2014 19:51, Robert Collins <robe...@robertcollins.net> wrote:
> It probably needs to be backed out of stable/icehouse. The issue is
> that we were installing unittest2 via distro packages *and* testtools
> new dependency on unittest2 did not express a minimum version.
>
> We're just about to issue 1.2.1 which will have such a minimum version.
>
> And for the record, this was released on saturday, not friday :).
>
> -Rob

We've discussed this on IRC, but I fail to see how this is an
appropriate fix for stable/* . This would mean introducing new minima
to stable branches, which for stable branches is totally
inappropriate.

This causes the effect of both distros and deployers requiring a
higher version which they have not planned for.  If we pin
oslo.messaging (which is what we started agreeing in Paris), this
problems goes away.

--
Kind Regards,
Dave Walker

_______________________________________________
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to