On 11/15/2014 02:51 PM, Robert Collins wrote: > It probably needs to be backed out of stable/icehouse. The issue is > that we were installing unittest2 via distro packages *and* testtools > new dependency on unittest2 did not express a minimum version. > > We're just about to issue 1.2.1 which will have such a minimum version. > > And for the record, this was released on saturday, not friday :).
Damn you and your living in the future! :) Honestly, though, the requirements change was !=1.2.0, so it does the right thing of just blocking the 1 version that depending on new unittest2 but isn't explicit about it. I made it very narrow for a reason, as I assumed it would get fixed in the next released version, and we'd be rolling again. It looks like 1.3.0 did just that, which is great. Thanks for looking at this and getting a fix out Robert. -Sean -- Sean Dague http://dague.net _______________________________________________ OpenStack-dev mailing list OpenStackfirstname.lastname@example.org http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev