Maybe we should ask for cap eventlet to 0.15.2 in global-requirements ?

Adding the [all] tag as I think it's cross-project.

-Sylvain


Le 06/01/2015 18:01, Daniel P. Berrange a écrit :
On Tue, Jan 06, 2015 at 05:36:38PM +0100, Ihar Hrachyshka wrote:
On 01/06/2015 05:33 PM, Daniel P. Berrange wrote:
On Tue, Jan 06, 2015 at 10:21:10AM -0600, Matt Riedemann wrote:
Odd...eventlet 0.16.0 was released on 12/30 and the eventlet.util import is
still in the libvirt host module, but this isn't blowing up in the Jenkins
runs, so what's different?  There isn't a version cap on eventlet in
global-requirements either.
When I pip install it in my dev env it still pulls in 0.15.2.

Likewise looking at a jenkins log from today it pulls in 0.15.2

   
http://logs.openstack.org/89/140089/3/check/gate-nova-python27/55b24ee/tox/py27-1.log

But the pypi page refers to 0.16.0

   https://pypi.python.org/pypi/eventlet/

?!?!?

Maybe some external dependency pulls in older version?
Ah, it seems my devpi/wheel caching setup was not seeing the new version.
When I forced a refresh in that, it pulled down 0.16.0 Wonder if the gate
has a similar cache refresh issue

Regards,
Daniel


_______________________________________________
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to