On 01/14/2015 04:08 AM, Dr. Jens Rosenboom wrote:
> Am 14/01/15 um 05:17 schrieb Adam Gandelman:
>> So eventlet 0.16.x has started hitting slaves and breaking stable
>> branches
>> (its not like we weren't warned :\ )
>>
>> https://bugs.launchpad.net/nova/+bug/1410626
>>
>> Should hopefully be resolved by eventlet versions caps in icehouse +
>> juno's
>> requirements:
>>
>> https://review.openstack.org/#/q/I4bbbeb5bf9c22ed36f5c9a74fec6b487d2c15697,n,z
>>
> 
> It was discussed already in the context of
> https://bugs.launchpad.net/nova/+bug/1407685 that capping eventlet would
> not be the proper solution, instead there is a fix already in master
> which has backports to icehouse + juno pending:
> 
> https://review.openstack.org/#/c/145955/
> https://review.openstack.org/#/c/146096/
> 
> Or is this new bug triggered by a different piece of code relating to
> the newly released eventlet 0.16.1?

Capping in stable/* is fine. A real openstack installation will not
randomly rev all the dependent libraries to a latest version. Assuming
that they will do so is misguided at best.

There was real concern in getting master to work correctly, which was
done. But for stable, capping is the right answer.

        -Sean

-- 
Sean Dague
http://dague.net

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to