Hi All,

There was a change [1] 2 days ago in django-openstack-auth that introduces a 
new requirement oslo.config>=1.6.0 to the project, which is now present in the 
1.1.9 release of django-openstack-auth. While this change is in sync with 
master requirements, oslo.config>=1.6.0, it does not jive with stable/icehouse 
requirements which is >=1.2.0,<1.5. Because stable/icehouse horizon does not 
have an upper-bound version requirement for django-openstack-auth, it currently 
takes this 1.1.9 release of django-openstack-auth with the conflicting 
oslo.config requirement. I have a bug open for this situation here [2].

My first thought was to create a patch [3] to cap the django-openstack-auth 
version in stable/icehouse requirements, however, a reviewer pointed out that 
django-openstack-auth 1.1.8 has a security fix that would be desired. My other 
thought was to decrease the minimum required version in django-openstack-auth 
to equal that of stable/icehouse requirements but this would then conflict with 
master requirements. Does anyone have thoughts on how to best resolve this?

Thank you,

[2] https://bugs.launchpad.net/horizon/+bug/1415243
[3] https://review.openstack.org/#/c/150612/
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe

Reply via email to