-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 02/04/2015 11:20 AM, Alan Pevec wrote:
>> Bumping minimal oslo.config version due to the issue in 
>> django-openstack-auth seems like a wrong way to do it.
> 
> Dependencies in requirements.txt do not seem to be used in 
> stable/icehouse gate jobs, recent pip freeze in stable/icehouse
> shows: ... oslo.config==1.6.0 # git sha 99e530e 
> django-openstack-auth==1.1.9 # git sha 2079383
> 

It's because of this:

2015-01-27 19:33:44.152 | Collecting oslo.config>=1.4.0 (from
python-keystoneclient>=0.11.1->python-openstackclient<=1.0.1)

After that installs 1.6.0, consequent pip runs assume that 1.6.0 is
always better than <1.4.0 and disregards version cap, hence does not
downgrade the library.

Should we finally cap versions for clients so that they don't fetch
new library versions?

/Ihar
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQEcBAEBAgAGBQJU0fpHAAoJEC5aWaUY1u57AwUIAJdW7ZBrknVyaAn0VIkty180
r49gYGEWaQCF7nMVzcnWKrs6aG3VOEJpyipAujzk0A2rF/gD9Bn9iHk2/hyjF/sZ
iDmokiDuFPAB8pIpYdMNyYyKKMgCGoInyHW1PAbCIsj24qiFIzSQMbojvt8Bsgks
68gQk5CYXmi0gF6OiPUHEqj73vpPjXLNZHd2V/P87MAvsTiGRXXFWncT0F1cl5oJ
i47uVOyhBK9zfZgDFfL/jPq35Ij71t9BXUQxdgxXavYbGjsnC+YEcOeAacUS4kBk
hDliIq+HGPGK0eEgLe4BwHxrd5Skh60h0TPsx+BbVo8A0mydxee7XgUxEG2P2Fs=
=sy8K
-----END PGP SIGNATURE-----

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to