>> Dependencies in requirements.txt do not seem to be used in
>> stable/icehouse gate jobs, recent pip freeze in stable/icehouse
>> shows: ... oslo.config==1.6.0 # git sha 99e530e
>> django-openstack-auth==1.1.9 # git sha 2079383
>
> It's because of this:
>
> 2015-01-27 19:33:44.152 | Collecting oslo.config>=1.4.0 (from
> python-keystoneclient>=0.11.1->python-openstackclient<=1.0.1)
>
> After that installs 1.6.0, consequent pip runs assume that 1.6.0 is
> always better than <1.4.0 and disregards version cap, hence does not
> downgrade the library.
>
> Should we finally cap versions for clients so that they don't fetch
> new library versions?

Clients are capped in stable/icehouse requirements but devstack in
gate seems to be installing them from git master (note # git sha)


Cheers,
Alan

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to