On 29 January 2015 at 04:57, Chris Friesen <chris.frie...@windriver.com>
wrote:

> On 01/28/2015 10:33 PM, Mathieu Gagné wrote:
>
>> On 2015-01-28 11:13 PM, Chris Friesen wrote:
>>>
>>> Anyone have any suggestions on where to start digging?
>>>
>> We have a similar issue which has yet to be properly diagnosed on our
>> side.
>>
>> One workaround which looks to be working for us is enabling the "private
>> mode"
>> in the browser. If it doesn't work, try deleting your cookies.
>>
>> Can you see if those workarounds work for you?
>>
>
> Neither of those seems to work for me.  I still get a multi-second delay
> and then the red bar with "Connect timeout".
>
> I suspect it's something related to websockify, but I can't figure out
> what.
>

In some versions of websockify and the relates noVNC versions that use it
I've seen the same behaviour. This is due to the way websockify tries to
detect the protocol to use. It ends up doing a localhost connection and the
browser rejects it as an unsafe operation.

It was fixed in later versions of websockify.

Have you tried manually updating the NoVNC and websockify files to later
versions from source?
__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to