Hi,

As you know a few of us have been spending way too much time digging
stable/juno out of the ditch its currently in. And just when we thought we
were in the clear a new library was released without a requirements cap in
stable global-requirements and broke stable/juno grenade.  Everytime this
happens we risk breaking everything. While there is a good long term fix in
progress (pin all of stable/juno https://review.openstack.org/#/c/147451/),
this will take a bit of time to get right and land.

The  good news is there is a nice easy interim solution. Before releasing a
new library go to stable/juno and stable/icehouse global requirements and
check if $library has a version cap, if not add one. And once that lands go
ahead and release your library. For example:
https://review.openstack.org/#/c/154715/2
__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to