On Thu, 13 Aug 2015, John kerry wrote:

Hi,

i will check whether this is driver issue or Luci,

I have to add " disable WPS if this feature is enabled for the WiFi module"
this in wireless. How i can handle this.

??? is this something you want to happen? something that happens that you don't want? we can't read your mind.

David Lang


Thanks,

On Thu, Aug 13, 2015 at 2:18 PM, David Lang <da...@lang.hm> wrote:

On Thu, 13 Aug 2015, John kerry wrote:

But i dont think so this driver might be the problem, Because when i am
doing using GUI its working so there will be not driver problem.

Just i am not getting how to add this in build config.

Normally what will be the wireless config for the repeater mode default.


the exact file that you create as a result of the GUI is what you would
put in the build config. But you say that you don't want that file because
you want to connect to different SSIDs on different channels, so you don't
_have_ any one file that you want to put in the default.

When you use LUCI to scan and attach to a different SSID, you say that it
looses the config for the local systems to connect to it. This could be a
LUCI problem, or it could be that the driver requires that this be reset
afterwords.

If it's a LUCI problem, you will have to fix that code (or go to where
tehy develop it and convince them to fix it). If it's a driver problem you
are out of luck.

But we can't tell you a file to put in the build that will connect to any
remote system because there isn't one file that will automatically connect
to any of several remote systems.

David Lang


On Thu, Aug 13, 2015 at 11:40 AM, David Lang <da...@lang.hm> wrote:

If you want to have one config thaqt will talk to many different APs with
different names/configs you are asking for magic. You have to change the
config to talk to the different destinations.

Since you are using a non-mainline driver, we don't know what the driver
s
able to do.

It sounds as if there is a problem that could either be in the driver or
in LUCI that makes it loose the rest of the config when you have it scan
for networks.

you can probably avoid that by just changing the info in the file to be
appropriate for the new environment and restarting wifi/rebooting. If you
want to do this via the existing GUI you will need to make code changes
to
LUCI.

But at this point you are talking custom stuff.

David Lang


On Thu, 13 Aug 2015, John kerry wrote:

Hi,


Still i am not able to configure wireless config file. The problem i am
facing, i cannot add fixed router name and password. It should every
time
scan and connect to any router. If i used GUI one config its fixed to
that
router which i connected. So with that configuration we are not able to
scan again and connect to any other router next time.



On Wed, Aug 12, 2015 at 9:29 AM, John kerry <kerry9...@gmail.com>
wrote:

Yes i able to config using GUI, But when i am configuring GUI i scan and

connect to one AP and then add one more AP mode to it. So finally i
will
have wireless configuration.

But i cant keep this config in build option because if i load this
configuration it will load what i connected last time, so next time i
cant
scan it anymore it showing the same connected to last AP.




On Wed, Aug 12, 2015 at 1:36 AM, David Lang <da...@lang.hm> wrote:

I thought you said a couple posts ago that you were able to configure
it

through the GUI to work the way you wanted it to, you were just
wanting
to
make something the default.

So do you have it working or not?

If you have it working, it should keep working after a reboot. What
are
you meaning when you say that you want to change the default?

Are you meaning that you want to create an image that will behave this
way when you do a factory reset (or when you first flash it)? If so,
then
you need to take your working config and make it part of your image
via
the
files/ mechansim.

If you are meaning something else, I'm still not understanding what
you
are trying to do.

David Lang



On Tue, 11 Aug 2015, John kerry wrote:

Date: Tue, 11 Aug 2015 21:20:58 +0800


From: John kerry <kerry9...@gmail.com>
To: David Lang <da...@lang.hm>
Cc: Alex Weedy <weedy2...@gmail.com>,
    OpenWrt Development List <openwrt-devel@lists.openwrt.org>
Subject: Re: [OpenWrt-Devel] Fwd: "3-address Wi-Fi bridging" (was:
Multiple
    Wi-Fi client/AP interfaces on one radio)

Hi,

How to config wireless config file for repeater mode. I am not able
to
config.

On Tue, Aug 11, 2015 at 5:34 PM, John kerry <kerry9...@gmail.com>
wrote:

When i load firmware the wireless config will be like below:


config wifi-device 'wifi0'
        option type 'qcawifi'
        option macaddr '00:26:75:bd:37:24'
        option hwmode '11ng'
        option txpower '16'
        option htmode 'HT20'
        option disabled '0'
        option channel '1'

config wifi-iface
        option device 'wifi0'
        option mode 'ap'
        option ssid 'Test_ap'
        option network 'lan'
        option encryption 'psk2'
        option key 'Test_ap'
        option wds '1'

so it works as Access point, i can connect to it any devices. When i
scan
it shows me list of devices then connect to anyone. then the
wireless
config  will becomes like below:

config wifi-device 'wifi0'
        option type 'qcawifi'
        option macaddr '00:26:75:bd:37:24'
        option hwmode '11ng'
        option txpower '16'
        option htmode 'HT20'
        option disabled '0'
        option channel '1'

config wifi-iface
        option network 'wwan'
        option ssid 'D-link-Router'
        option encryption 'psk2'
        option device 'wifi0'
        option mode 'sta'
        option key '0010069039'
        option wds '1'

Then i add one more ap mode so wireless config becomes,
config wifi-device 'wifi0'
        option type 'qcawifi'
        option macaddr '00:26:75:bd:37:24'
        option hwmode '11ng'
        option txpower '16'
        option htmode 'HT20'
        option disabled '0'
        option channel '1'

config wifi-iface
       option network 'wwan'
        option ssid 'D-link-Router'
        option encryption 'psk2'
        option device 'wifi0'
        option mode 'sta'
        option key '0010069039'
        option wds '1'

config wifi-iface
        option device 'wifi0'
        option mode 'ap'
        option ssid 'Test_ap'
        option network 'lan'
        option encryption 'psk2'
        option key 'Test_ap'
        option wds '1'

This i added manually one ap mode.

So if i copy this config file, build and load this firmware, its
load
what
it was there so it shows one client which i was connected last time
and
one
AP which i added.

But now i cannot scan anymore and connect to new router instead of
old
client.

This is the problem i am facing.

Basically i need to configure the wireless file for repeater mode.

So after connecting to another router this SSID still should be
there
and
other device can connect to it.

On Tue, Aug 11, 2015 at 4:30 PM, David Lang <da...@lang.hm> wrote:

you have a working config


but you want to do something by default

what you want to do is different at different times.

what is it that you want to be the default? when do you want this
default
to apply? This isn't clear.

David Lang

On Tue, 11 Aug 2015, John kerry wrote:

Date: Tue, 11 Aug 2015 15:51:38 +0800

From: John kerry <kerry9...@gmail.com>

To: David Lang <da...@lang.hm>
Cc: Alex Weedy <weedy2...@gmail.com>,
    OpenWrt Development List <openwrt-devel@lists.openwrt.org>
Subject: Re: [OpenWrt-Devel] Fwd: "3-address Wi-Fi bridging" (was:
Multiple

    Wi-Fi client/AP interfaces on one radio)

Yes,

i can copy the config and build with this configuration,

for example now i have connected to some router, another time we
can
connect to any router. So how i can fix the settings by default.

On Tue, Aug 11, 2015 at 12:45 AM, David Lang <da...@lang.hm>
wrote:

On Mon, 10 Aug 2015, John kerry wrote:


I followed the same steps and its working too. But this i want in
wireless

config file, Because i dont want every time to add using GUI. So

When i
connect to another router also, no need to add one more. I mean
to
say
it
should be in default wireless config file.


what do you mean by "default wireless config file"


Once you have set it from the GUI, it is in the config files. The
next
time you boot it will use that config.

If you mean that you want it in the factory default config (for
when
you
first flash the router or do a factory reset), then take the
/etc/config/wireless and /etc/config/network files and add them
to
your
build under /files

David Lang


On Mon, Aug 10, 2015 at 6:18 PM, David Lang <da...@lang.hm>
wrote:


On Mon, 10 Aug 2015, John kerry wrote:



Date: Mon, 10 Aug 2015 18:10:14 +0800


From: John kerry <kerry9...@gmail.com>

To: Alex Weedy <weedy2...@gmail.com>,

    OpenWrt Development List <openwrt-devel@lists.openwrt.org

Subject: [OpenWrt-Devel] Fwd: "3-address Wi-Fi bridging" (was:
Multiple
Wi-Fi
    client/AP interfaces on one radio)

Firstly i configure wireless config as below:

config wifi-device 'wifi0'
       option type 'qcawifi'
       option macaddr '00:01:11:00:01:00'
       option hwmode '11ng'
       option txpower '17'
       option htmode 'HT20'
       option disabled '0'
       option channel '1'

config wifi-iface
       option device 'wifi0'
       option mode 'ap'
       option ssid 'Testing_ap'
       option network 'lan'
       option encryption 'psk2'
       option key 'Testing_ap'

so its SSID was showing and able to connect any device to it.

Then i scan the device and connect to one of it. While joining
the
network
i selected Client(WDS) then the wireless config becomes like
below:


why don't you try following the steps in the video that you
posted.


first connect as a client, then add an additional interface
and
make
the
second interface the AP for things to connect to.

the order may make a difference.

David Lang


config wifi-device 'wifi0'

       option type 'qcawifi'

       option macaddr '00:01:11:00:01:00'

       option hwmode '11ng'
       option txpower '17'
       option htmode 'HT20'
       option disabled '0'
       option channel '1'

config wifi-iface
       option network 'wwan'
       option ssid 'D_Link_Router'
       option encryption 'psk2'
       option device 'wifi0'
       option mode 'sta'
       option key 'Dlink_Router'
       option wds '1'

Then  i added one as shown in the video. Now its connected to
router
also
and this add one also showing so i can connect to this also.

But i am not getting how to keep this in default wireless
config.

Because every time we cant add one to configure like this. It
should
be
like default should be in ap mode so any device we can
connect,
if
its
connected to another router also that SSID still should be
visible
and
able
to connect to this.




On Mon, Aug 10, 2015 at 2:57 PM, John kerry <

kerry9...@gmail.com>
wrote:


When i try to configure based on video, its shows 2 one as
client

another

one as Master but i am not able to enable it . I mean to say
wireless

becomes disable. If i enable it using GUI also its not

happening.

On Mon, Aug 10, 2015 at 2:55 PM, David Lang <da...@lang.hm>
wrote:

What happens when you try to follow the video?


Based on your comments, i'm guessing that things don't work
when

you
try
and configure the second network and have it with a
different
SSID
than
the
first network that you put in client mode.

Is this correct?

David Lang

On Mon, 10 Aug 2015, John kerry wrote:

Yes, When i am connecting to Another router its changed to
Client
mode.


Can i configure this in repeater mode like its shows in
below
link:


https://www.youtube.com/watch?v=3rbsh2zxPnk




_______________________________________________



openwrt-devel mailing list


openwrt-devel@lists.openwrt.org


https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel















_______________________________________________
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel

Reply via email to