Hi Wojtek,

Turning on AlphaTest/AlphaFunc is not mutually exclusive with RenderBin
override. I don't want to make decision that has to be its either this or
that. I would like to leave RenderBin override as default. I would also add
setShadowMapRenderingSettings/getShadowMapRenderingSettings methods to allow
user turn it off if he decides. So my conclusion is I would like to add the
submission as sent to the codebase.

Excellent, I agree with this. I tested your code and it works for me, so you can send it to osg-submissions whenever you want.

I could suggest that instead of using

    OVERRIDE_RENDER_BINS_WITH_OPAQUE_BIN = 1,
    SET_COLOR_MASK_TO_FALSE = 2,

you use the bit shift notation, which I find easier to read and maintain (and please align the values... :-) ):

    OVERRIDE_RENDER_BINS_WITH_OPAQUE_BIN = 1 << 0,
    SET_COLOR_MASK_TO_FALSE              = 1 << 1,
    SOME_OTHER_SETTING                   = 1 << 2,

but that's just a style issue and subject to personal taste.

Also you could add a doxygen comment for the ShadowMapRenderingSettings enum, which would explain what the values are useful for. Otherwise, it's pretty cryptic for users (unless they search the mailing lists and find this thread :-) ).

J-S
--
______________________________________________________
Jean-Sebastien Guay    [EMAIL PROTECTED]
                               http://www.cm-labs.com/
                        http://whitestar02.webhop.org/
_______________________________________________
osg-users mailing list
osg-users@lists.openscenegraph.org
http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org

Reply via email to