Hi All, While updating the OpenSceneGraph/NEWS.txt and associated press release for the 3.6.0 release I spotted an error in the naming of the osg::ComputeDispatch class. This class wraps up glDispatchCompute so to be consistent with the rest of the OSG/GL naming convention this class should be called osg::DispatchCompute. To avoid confusion in the future I've decided to rename this class. Those small number of developers using OSG master/3.5.x dev series and that have used the osg::ComputeDispatch class they will need to rename it in their applications to get things to compile. Unfortunately any .osgt/.osgb files that contain ComputeDispatch entries, you'll need to regenerate these with the new names as I haven't been able to work out how to retain backwards compatibility.
I hate doing such changes right before a release but I felt being consistent is important and better to do the rename before many others start adopting the incorrectly named class. Fingers crossed there won't be any breakages in cross platform build with this change. The latest changes I've mad to the 3.6 branch are wrapped up in the commit: https://github.com/openscenegraph/OpenSceneGraph/commit/7ab1208c65b4d7fa67cb6031e905d7d67a3b9389 I still plan to tag 3.6.0 today as I'm off on trip tomorrow and won't have time to do it once I'm away. Robert. _______________________________________________ osg-users mailing list firstname.lastname@example.org http://lists.openscenegraph.org/listinfo.cgi/osg-users-openscenegraph.org