https://bugzilla.redhat.com/show_bug.cgi?id=1507103



--- Comment #79 from digimer <digi...@alteeve.ca> ---
I applied the changes and hit an odd build error against just epel7 on x86_64
pulling in an unexpected RPM on koji. Bumped again from 1.1-5 to -6 to add a
version restriction to deal with it. Diff against -4 to -6 below.

New .spec and srpm:
https://www.alteeve.com/an-repo/files/packages/kronosnet.spec.1.1-6
https://www.alteeve.com/an-repo/files/packages/kronosnet-1.1-6.fc27.src.rpm

f26:
https://koji.fedoraproject.org/koji/taskinfo?taskID=25534544

f27:
https://koji.fedoraproject.org/koji/taskinfo?taskID=25534556

f28:
https://koji.fedoraproject.org/koji/taskinfo?taskID=25534564

rawhide:
https://koji.fedoraproject.org/koji/taskinfo?taskID=25534572

epel7:
https://koji.fedoraproject.org/koji/taskinfo?taskID=25534493


Diff from 1.1-4:
====
--- kronosnet.spec.1.1-4    2018-03-04 02:00:23.290918796 -0500
+++ kronosnet.spec.1.1-6    2018-03-07 01:19:35.321125418 -0500
@@ -70,7 +70,7 @@
 Name: kronosnet
 Summary: Multipoint-to-Multipoint VPN daemon
 Version: 1.1
-Release: 4%{?dist}
+Release: 6%{?dist}
 License: GPLv2+ and LGPLv2+
 URL: http://www.kronosnet.org
 Source0: http://www.kronosnet.org/releases/kronosnet-%{version}.tar.gz
@@ -93,7 +93,7 @@
 BuildRequires: pkgconfig(zlib)
 %endif
 %if %{defined buildcompresslz4}
-BuildRequires: pkgconfig(liblz4)
+BuildRequires: pkgconfig(liblz4) >= 1.7
 %endif
 %if %{defined buildcompresslzo2}
 BuildRequires: lzo-devel
@@ -257,9 +257,7 @@
 %license COPYING.* COPYRIGHT
 %{_libdir}/libtap.so.*

-%ldconfig_scriptlets libtap1
-
-%postun -n libtap1 -p /sbin/ldconfig
+%ldconfig_scriptlets -n libtap1

 %package -n libtap1-devel
 Summary: Simple userland wrapper around kernel tap devices (developer files)
@@ -299,9 +297,7 @@
 %{_libdir}/libknet.so.*
 %dir %{_libdir}/kronosnet

-%post -n libknet1 -p /sbin/ldconfig
-
-%postun -n libknet1 -p /sbin/ldconfig
+%ldconfig_scriptlets -n libknet1

 %package -n libknet1-devel
 Summary: Kronosnet core switching implementation (developer files)
@@ -314,13 +310,6 @@
 Please refer to the not-yet-existing documentation for further
 information. 

-# libknet.pc leading to pkgconfig(libknet) automatic virtual provides,
-# like other files, is not explicitly versioned in the name like the
-# subpackages are -- intention of doing so for subpackage names is
-# to ease the cross-checking the compatibility of the remote clients
-# interchanging data using this network communication library, as
-# the number denotes the protocol version (providing multiple
-# protocol versions in parallel is not planned).
 %files -n libknet1-devel
 %{_libdir}/libknet.so
 %{_includedir}/libknet.h
@@ -469,10 +458,25 @@
 %files -n libknet1-plugins-all

 %if %{with rpmdebuginfo}
+# libknet.pc leading to pkgconfig(libknet) automatic virtual provides,
+# like other files, is not explicitly versioned in the name like the
+# subpackages are -- intention of doing so for subpackage names is
+# to ease the cross-checking the compatibility of the remote clients
+# interchanging data using this network communication library, as
+# the number denotes the protocol version (providing multiple
+# protocol versions in parallel is not planned).
 %debug_package
 %endif

 %changelog
+* Wed Mar 07 2018 Madison Kelly <mke...@alteeve.ca> - 1.1-6
+- Added a version requirement to lz4 to deal with koji pulling in the
+  wrong package.
+
+* Tue Mar 06 2018 Madison Kelly <mke...@alteeve.ca> - 1.1-5
+- Updated ldconfig scriptlet calls.
+- Moved the debug_package leading comment.
+
 * Sun Mar 04 2018 Madison Kelly <mke...@alteeve.ca> - 1.1-4
 - Removed leading spaces from descriptions.
 - Added the (commented out) %%check tests.
@@ -493,45 +497,3 @@
 - Removed the (no longer needed) gcc8-fixes.patch
 - Added the new doxygen and libqb-devel buildrequires for libknetd.

-* Fri Feb 23 2018 Madison Kelly <mke...@alteeve.ca> - 1.0-10
-- Added missing change log for 1.0-9.
-
-* Thu Feb 22 2018 Madison Kelly <mke...@alteeve.ca> - 1.0-9
-- Changed the source tarball to be one from the upstream source.
-- Updated the main license.
-- Moved down the %%{?systemd_requires} macro.
-
-* Fri Feb 16 2018 Madison Kelly <mke...@alteeve.ca> - 1.0-8
-- Reverted to 'BuildRequires: bzip2-devel' to fix EPEL7 builds.
-
-* Thu Feb 15 2018 Madison Kelly <mke...@alteeve.ca> - 1.0-7
-- Added missing 1.0-6 changelog.
-- Added kronosnetd postun.
-- Clarified licensing.
-- (re)added systemd_requires.
-- Wrapped several buildrequires with pkgconfig().
-
-* Wed Feb 14 2018 Madison Kelly <mke...@alteeve.ca> - 1.0-6
-- Removed sysvinit checks.
-- Fixed the groupadd to add to system group.
-- Added build requirement for systemd.
-- Added %%{_isa} macro to knet requirements in sub packages.
-
-* Mon Feb 12 2018 Madison Kelly <mke...@alteeve.ca> - 1.0-5
-- All changes related to this spec;
-- Fixed typo in previous changelog date (Tue -> Wed).
-- Capitalized summaries as needed.
-- Changed Requires that were file paths to package names.
-- Added arch and version/release requirements for knet packages.
-- Changed groupadd to be a little smarter.
-
-* Wed Jan 31 2018 Madison Kelly <mke...@alteeve.ca> - 1.0-4
-- Added patch for gcc8 fix.
-- Cleaned up description.
-
-* Tue Jan 30 2018 Madison Kelly <mke...@alteeve.ca> - 1.0-3
-- Rebuild for Fedora release.
-
-* Tue Jan 30 2018 Autotools generated version <nob...@nowhere.org> -
1.0-1-48.d96b.
-- These aren't the droids you're looking for.
-
====

-- 
You are receiving this mail because:
You are on the CC list for the bug.
You are always notified about changes to this product and component
_______________________________________________
package-review mailing list -- package-review@lists.fedoraproject.org
To unsubscribe send an email to package-review-le...@lists.fedoraproject.org

Reply via email to