Uri Guttman <[EMAIL PROTECTED]> wrote:
> >>>>> "LW" == Larry Wall <[EMAIL PROTECTED]> writes:
>   LW> oct and hex are arguably misnamed, since most functions are named by
>   LW> what they produce, not by what they take as input.  I don't know what
>   LW> the replacement should be, though.  Maybe it's not worth fixing.
> 
> from_oct, from_hex which state what they do? or a more general
> from_base( 16, $hex )? and that could be curried into from_hex().

  0xFF.dec()
  $num.dec()
  $num.hex()
  $num.base($n)

?

I believe that some of these can already be handled by C<.as()>.

I would like for this to be addressed. This is one item that has
always confused me about Perl 5.

-- 
matt diephouse
http://matt.diephouse.com

Reply via email to