Eric skribis 2006-08-10 10:22 (-0600):
> I think .valid is an excellent argument for underscores all by itself.

I think it's an argument for reconsidering the name of that method.
"valueid" is only 2 characters more.

I'm personally against non-prefix underscores in any core identifier.

I agree that "valid" to mean "value ID" is a bad idea, though. It's
extremely ambiguous.

> I don't have any other arguments for _, but it would be interesting to
> hear the reasoning agianst it.

Forbidden underscore encourages the designers to think much harder about
the best name, because it automatically rules out things like "valid" if
you stick to sanity. It may be so that "value ID" itself is a bad name.

Also, having_underscores leads_to longer_names, in my experience. Longer
names are great for my own code, but I want core stuff to be consise and

> On 8/6/06, Ashley Winters <[EMAIL PROTECTED]> wrote:
> >On 8/6/06, Yuval Kogman <[EMAIL PROTECTED]> wrote:

Please do not answer above the quote.



Reply via email to