在 2006/8/11 下午 2:35 時，Luke Palmer 寫到：
I think that standard functions ought not to have underscores *most of the time*, because their presence indicates something that could be better named or is miscategorized. However, for methods, especially "advanced" or introspective methods, I think longer names that describe the action are better than short ones that only describe the action if you understand the pun. Huffman coding does not imply that *everything* is short.
.SKID and the like are methods of Object, and as such should be considered
part of the standard functions, as they are available to all terms.Methods for the other implicit-coerced-to types (Bit/Int/Num/Str/ List) share this concern; because all terms may be coerced implicitly into them, their
methods also have unbounded visibility.For other built-in types, I think underscore names are just fine. For example, metaclass methods such as "Class.has_method" should indeed remain as such. :)
Description: This is a digitally signed message part