Pessoal,

Minha experiência, com sucesso, no PG é 99.999% no windows. O 0.001% Linux foi o meu primeiro contato com o PG, aonde, somente me foi passado a senha, autorizações, como entrava e nem via o computador. Ainda era usado o enconding LATIN1!!!!!!


Pois bem, como aprendizado (e exigencia de cliente, rs rs) instalei um PG no linux.

Por enquanto só estou com um problema, que peço ajuda aqui. Até encontrei respostas, mas, as informações não estão batendo com o que tenho no meu ambiente, devido a serem antigas.

Linux CentOS 7, 32 bits

PG 9.6.1

Instalei usando o pacote de instalação do EnterpriseDB (OK, sei que tem gente que critica, mas, usei esse)

quando crio o banco, ele vai padronizado com:

ENCODING = 'UTF8'
LC_COLLATE = 'pt_BR.utf8'
LC_CTYPE = 'pt_BR.utf8'

Porém, o locale original, do sistema que estava em windows é "Portuguese_Brazil.1252" e fez com que as acentuações fossem todas distorcidas.

Já vi que não consigo criar no mesmo locale do windows e não estou conseguindo setar o banco com

/"pt_BR-ISO-8859-1", que segundo pesquisa, seria o correto. Me aparece a seguinte mensagem: CREATE DATABASE teste WITH OWNER = eduardoaz ENCODING = 'UTF8' TABLESPACE = pg_default LC_COLLATE = 'pt_BR-ISO-8859-1' LC_CTYPE = 'pt_BR-ISO-8859-1' CONNECTION LIMIT = -1; ERROR: invalid locale name: "pt_BR-ISO-8859-1" ********** Error ********** ERROR: invalid locale name: "pt_BR-ISO-8859-1" SQL state: 42809 Aonde encontrar explicações ou me passarem algumas dicas? Grato Eduardo Az /



_______________________________________________
pgbr-geral mailing list
pgbr-geral@listas.postgresql.org.br
https://listas.postgresql.org.br/cgi-bin/mailman/listinfo/pgbr-geral

Responder a