Andres Freund <[email protected]> writes:
> I think the GinLogicValueEnum is supposed to be an enum's name, not a
> variable name, right?

I think the whole thing is too cute by half.  Why isn't it just

typedef enum GinLogicValue
{
    GIN_FALSE = 0,           /* item is present / matches */
    GIN_TRUE = 1,            /* item is not present / does not match */
    GIN_MAYBE = 2            /* don't know if item is present / don't know if
                              * matches */
} GinLogicValue;

instead of thinking that we are smarter than the compiler about how
to store the enum?  For that matter, those explicit specifications of
the enum tag numeric values seem unnecessary and bad style IMV.

                        regards, tom lane


-- 
Sent via pgsql-committers mailing list ([email protected])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-committers

Reply via email to