Sami Imseih <[email protected]> writes:
> While looking at this, I realized that "PqMsg_Progress" is the name of the
> 'P' message that was added for parallel index progress reporting.

> I missed [1] at the time, but if there is still a chance to rename it to
> "PqMsg_ParallelWorkerProgress", that seems better,
> "PqMsg_Progress" does not really describe what it is, whereas
> "PqMsg_ParallelWorkerProgress" makes it explicit that this is a
> parallel-worker-to-leader message. It also matches other places in the code
> that deal with parallel workers, such as "IsParallelWorker", so it is easier
> to find when looking through parallel-worker code.

Yeah, "PqMsg_Progress" seems unduly generic.  I don't think we should
rename it in the back branches, but doing so in master looks like
it'd be a small-footprint change.

                        regards, tom lane


Reply via email to