Hi, Thanks for the feedback!
On Thu, Sep 10, 2026 at 9:30 AM Nathan Bossart <[email protected]> wrote: > > On Wed, Sep 09, 2026 at 06:35:55PM -0400, Tom Lane wrote: > > Sami Imseih <[email protected]> writes: > >> While looking at this, I realized that "PqMsg_Progress" is the name of the > >> 'P' message that was added for parallel index progress reporting. > > > >> I missed [1] at the time, but if there is still a chance to rename it to > >> "PqMsg_ParallelWorkerProgress", that seems better, > >> "PqMsg_Progress" does not really describe what it is, whereas > >> "PqMsg_ParallelWorkerProgress" makes it explicit that this is a > >> parallel-worker-to-leader message. It also matches other places in the code > >> that deal with parallel workers, such as "IsParallelWorker", so it is > >> easier > >> to find when looking through parallel-worker code. > > > > Yeah, "PqMsg_Progress" seems unduly generic. I don't think we should > > rename it in the back branches, but doing so in master looks like > > it'd be a small-footprint change. > > All of the options I've seen listed in this thread so far involve changing > the part after the PqMsg_ prefix, but given we now have PqReplMsg_ and > PqBackupMsg_, I'm thinking it'd be better to give parallel worker messages > their own prefix. That seems to act as a sort of class or namespace for > the message. Maybe something like PqParallelMsg_Progress would work here. I think PqParallelMsg_Progress makes sense. The attached does this. -- Sami Imseih Amazon Web Services (AWS)
v1-0001-Rename-PqMsg_Progress-to-PqParallelMsg_Progress.patch
Description: Binary data
