On Wednesday, September 16, 2026 12:51 PM Peter Smith <[email protected]> wrote: > Some review comments for v3: > > > ====== > src/backend/catalog/aclchk.c > > + case OBJECT_PUBLICATION_EXCLUDED_REL: > case OBJECT_PUBLICATION_NAMESPACE: > case OBJECT_PUBLICATION_REL: > > The new enum name OBJECT_PUBLICATION_EXCLUDED_REL is closely > related to OBJECT_PUBLICATION_REL. > > IMO, a better name would be OBJECT_PUBLICATION_REL_EXCLUDED, so > these related things are kept adjacent alphabetically and in the code.
I think all object type names end with a noun, whereas the proposed name doesn't, so I don't find it better. Also, the order of an enum value doesn't provide enough value to justify the change, in my view. Best Regards, Zhijie Hou
