On Jun 24, 2010, at 16:30 , Robert Haas wrote: > On Thu, Jun 24, 2010 at 10:13 AM, Tom Lane <t...@sss.pgh.pa.us> wrote: >> Simon Riggs <si...@2ndquadrant.com> writes: >>> On Wed, 2010-06-23 at 21:54 +0000, Robert Haas wrote: >>>> This adds four additional connection parameters to libpq: keepalives, >>>> keepalives_idle, keepalives_count, and keepalives_interval. >>>> keepalives default to on, per discussion, but can be turned off by >>>> specifying keepalives=0. The remaining parameters, where supported, >>>> can be used to adjust how often keepalives are sent and how many >>>> can be lost before the connection is broken. >> >>> There isn't any need at at all for this. We can already add options on >>> the libpq connection line. >> >>> options = '-o tcp_keepalives_idle=X >>> tcp_keepalives_interval=Y >>> tcp_keepalives_count=Z' >> >> Huh? The above is 100% fanciful; there was no code in libpq or anywhere >> else that would have processed such a thing. > > You can do this: > > psql "host=127.0.0.1 options='-c tcp_keepalives_idle=1'"
Hm, seems a bit error-prone though. The difference between the above psql "host=127.0.0.1 keepalives=1" isn't immediately obvious I'd say. Should we maybe rename the libpq-side parameters to tcp_client_keepalives, tcp_client_keepalives_idle, tcp_client_keepalives_count and tcp_client_keepalives_interval? Or do we expect people who fiddle with those parameters to understand the subtle difference? best regards, Florian Pflug -- Sent via pgsql-hackers mailing list (email@example.com) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers