On Thu, Jun 24, 2010 at 10:40 AM, Florian Pflug <f...@phlo.org> wrote:
> On Jun 24, 2010, at 16:30 , Robert Haas wrote:
>> On Thu, Jun 24, 2010 at 10:13 AM, Tom Lane <t...@sss.pgh.pa.us> wrote:
>>> Simon Riggs <si...@2ndquadrant.com> writes:
>>>> There isn't any need at at all for this. We can already add options on
>>>> the libpq connection line.
>>>> options = '-o tcp_keepalives_idle=X
>>>> tcp_keepalives_interval=Y
>>>> tcp_keepalives_count=Z'
>>> Huh?  The above is 100% fanciful; there was no code in libpq or anywhere
>>> else that would have processed such a thing.
>> You can do this:
>> psql "host= options='-c tcp_keepalives_idle=1'"
> Hm, seems a bit error-prone though. The difference between the above
> psql "host= keepalives=1"
> isn't immediately obvious I'd say.
> Should we maybe rename the libpq-side parameters to tcp_client_keepalives, 
> tcp_client_keepalives_idle, tcp_client_keepalives_count and 
> tcp_client_keepalives_interval? Or do we expect people who fiddle with those 
> parameters to understand the subtle difference?

I think the existing names are fine - people should understand that
"options" means "server-side options" and that anything else is a
client-side option.  However, if there's a strong consensus the other
way and someone feels like working up a patch, that's fine too.

Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise Postgres Company

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to