2013/2/19 Josh Berkus <j...@agliodbs.com>: > >>> I've come to value greppability of source code pretty highly. I think >> that >>> some of the points you raise are valid, but in my (minority) opinion >>> overloading creates more problems than it solves. You're not going to >>> convince me that get() is *ever* a good name for a function - you might as >>> well call it thing() or foo() for all the useful information that name >> conveys. > > What about extract()? That's consistent with the function we already > use for timestamps and intervals, and is more clear than get().
"extract" is not usual function, it is supported by parser, and in this time nobody knows datatypes, so result can be some ugly error messages Regards Pavel > > On the other hand, to_string() seems like a GREAT name for an overloaded > function. You know that it takes some other type as an argument, > possibly several other types, and will always output a string. > > -- > Josh Berkus > PostgreSQL Experts Inc. > http://pgexperts.com > > > -- > Sent via pgsql-hackers mailing list (firstname.lastname@example.org) > To make changes to your subscription: > http://www.postgresql.org/mailpref/pgsql-hackers -- Sent via pgsql-hackers mailing list (email@example.com) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers