> -----Original Message----- > From: pgsql-hackers-ow...@postgresql.org [mailto:pgsql-hackers- > ow...@postgresql.org] On Behalf Of Robert Haas > Sent: 19 February 2013 15:05 > To: Merlin Moncure > Cc: David E. Wheeler; PostgreSQL-development Hackers > > The argument for removing json_ prefix is that when function behaviors > > are unambiguously controlled by the arguments, decorating the function > > name to match the input argument is unnecessary verbosity. > > I've come to value greppability of source code pretty highly. I think that > some of the points you raise are valid, but in my (minority) opinion > overloading creates more problems than it solves. You're not going to > convince me that get() is *ever* a good name for a function - you might as > well call it thing() or foo() for all the useful information that name conveys.
Let me join the minority here, +1 Regards Petr Jelinek -- Sent via pgsql-hackers mailing list (firstname.lastname@example.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers