On 03/19/2014 06:57 PM, Peter Geoghegan wrote:
On Wed, Mar 19, 2014 at 9:28 AM, Andres Freund <and...@2ndquadrant.com> wrote:
* Jsonb vs JsonbValue is just bad, the latter needs to be renamed, and
there needs to be a very clear explanation about why two forms exist
and what each is used for.
I've pushed some comments to Github that further clarify the
I did not change the name of JsonbValue, because I sincerely could not
think of a better one. The distinction is subtle.
I didn't like the _state->state stuff either, but I think you changed
the wrong name - it's the field name in the struct that needs changing.
What you've done is inconsistent with the common idiom in jsonfuncs.c.
Sent via pgsql-hackers mailing list (email@example.com)
To make changes to your subscription: