On Thu, Jun 5, 2014 at 7:12 AM, Heikki Linnakangas
<hlinnakan...@vmware.com> wrote:
>>> BTW, what about also renaming pg_llog directory? I'm afraid that
>>> a user can confuse pg_log with pg_llog.
>> We have:
>> * pg_ldecoding (Heikki)
>> * pg_lcse or pg_lcset (Petr)
>> * pg_logical (Andres)
>> I like, what a surprise, my own suggestion best. The name seems more
>> versatile because it's not restricted to decoding.
> The problem with pg_logical is that it's not restricted to much at all ;-),
> "logical" is an awfully generic name.

True.  But we don't have anything else with which it's liable to be confused.

> BTW, the stuff that we have in pg_llog are not really logs at all, so
> pg_llog was always a misnomer.

Also true.

For my part, I'd strongly prefer a name based on the term "logical
decoding".  This feature has lots of names (change-set extraction,
logical replication, blah blah) and I worked pretty hard to make sure
that the core patch as committed referred to it in just one way
(logical decoding) everywhere.  I'd rather not call this pg_lcse or
pg_lcset or something like that because now we're introducing other
terminology that's not used elsewhere.  I'll defer to the group on
whether it should be called pg_logical or pg_logicaldecoding or
pg_logical_decoding or pg_ldecoding or pg_logdec or
pg_lOgIcAl___DECODing, but it should be something somehow based on
that term.

Robert Haas
EnterpriseDB: http://www.enterprisedb.com
The Enterprise PostgreSQL Company

Sent via pgsql-hackers mailing list (pgsql-hackers@postgresql.org)
To make changes to your subscription:

Reply via email to