2014-06-12 7:08 GMT+02:00 Tom Lane <t...@sss.pgh.pa.us>: > Noah Misch <n...@leadboat.com> writes: > > On Wed, Jun 11, 2014 at 11:57:20PM -0400, Tom Lane wrote: > >> Meanwhile, we have to either revert the addition of lo_create(oid, > >> bytea) altogether, or choose a different name for it. Suggestions? > > > lo_new() or lo_make()? An earlier draft of the patch that added > > lo_create(oid, bytea) had a similar function named make_lo(). > > I think we want to stick to the lo_xxx naming convention, whatever > xxx ends up being. > > I was idly thinking that we might want to focus on the fact that this > function not only creates a LO but loads some data into it. lo_make > isn't too bad, but we could also consider lo_load, lo_import, etc. > (lo_import is not one of the names we have to avoid overloading. > OTOH, there's already a 2-argument form of it, so maybe there'd be > issues with resolving calls with unknown-literal arguments.) > > I have not any problem with lo_new, lo_make. lo_import is related to import from host system. I am not sure about lo_load, but I am not able to specify arguments why not.
Pavel > regards, tom lane > > > -- > Sent via pgsql-hackers mailing list (email@example.com) > To make changes to your subscription: > http://www.postgresql.org/mailpref/pgsql-hackers >