On Tue, Apr 21, 2015 at 6:17 AM, Craig Ringer <[email protected]> wrote: >> I don't really like the 'pid' field for pg_replication_slots. About >> naming it 'active_in' or such? > > It was originally named active_pid, but changed based on feedback from > others that 'pid' would be consistent with pg_stat_activity and > pg_replication_slots. I have no strong opinion on the name, though I'd > prefer it reflect that the field does in fact represent a process ID.
Agreed. I don't like the as-committed name of active_in either. It's not at all clear what that means. -- Robert Haas EnterpriseDB: http://www.enterprisedb.com The Enterprise PostgreSQL Company -- Sent via pgsql-hackers mailing list ([email protected]) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers
