On Wed, Mar 23, 2016 at 1:36 PM, Petr Jelinek <p...@2ndquadrant.com> wrote: > Ok, I am happy with it, marked it as ready for committer (it was marked as > committed although it wasn't committed).
Thanks for fixing the status. I had forgotten about this thread. I can't really endorse the naming conventions here. I mean, we've got the main extensible nodes stuff in extensible.h, and then we've got this stuff in custom_node.h (BTW, there is a leftover reference to custom-node.h). There's no hint in the naming that this relates to scans, and why is it extensible in one place and custom in another? I'm not quite sure how to clean this up. At a minimum, I think we should standardize on "custom_scan.h" instead of "custom_node.h". I think that would be clearer. But I'm wondering if we should bite the bullet and rename everything from "custom" to "extensible" and declare it all in "extensible.h". src/backend/nodes/custom_node.c:45: indent with spaces. + } -- Robert Haas EnterpriseDB: http://www.enterprisedb.com The Enterprise PostgreSQL Company -- Sent via pgsql-hackers mailing list (firstname.lastname@example.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers