On 2016/04/04 17:25, Simon Riggs wrote:
> The rel cache code you're adding uses a flag called "rd_fkeyvalid" which
> indicates that the relcache is correctly filled. That is confusing, since
> it has nothing to do with the concept of constraint validity. We should
> rename that to rd_fkeycachefilled or similar.
Maybe I'm missing something, but is a separate bool required at all in
this case? Wouldn't simply doing the following suffice?
/* Quick exit if we already computed the list. */
ISTM, rd_fkeyvalid is modeled on rd_indexvalid, where the latter serves to
convey more info than simply whether the index list is valid or not, so
the extra field is justified.
Also, it seems the patch forgot to update RelationDestroyRelation().
Sent via pgsql-hackers mailing list (email@example.com)
To make changes to your subscription: