On Sun, Apr 24, 2016 at 2:23 PM, Tom Lane <t...@sss.pgh.pa.us> wrote: > FWIW, I agree with Bruce that using "degree" here is a poor choice. > It's an unnecessary dependence on technical terminology that many people > will not be familiar with.
And many others will. Some made-up term that is entirely PostgreSQL-specific is not going to be better. > Well, that just says that we'd better reconsider *both* of those names. > Frankly, neither of them is well chosen, and the fact that they currently > sound unrelated is a bug not a feature. What about something like > "max_overall_worker_processes" and "max_session_worker_processes"? The first one is fine except for the IMHO-fatal defect that max_worker_processes has been around since 9.4, and I think it's far too late to rename it. Should we rename max_connections to max_overall_connections at the same time? The second one is wrong for at least two reasons: it's not a per-session maximum, and it's not a maximum of all worker processes, just parallel workers. -- Robert Haas EnterpriseDB: http://www.enterprisedb.com The Enterprise PostgreSQL Company -- Sent via pgsql-hackers mailing list (firstname.lastname@example.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers