On Tue, Apr 26, 2016 at 11:34 AM, Tom Lane <t...@sss.pgh.pa.us> wrote:
> Robert Haas <robertmh...@gmail.com> writes:
>> On Tue, Apr 26, 2016 at 11:22 AM, Alvaro Herrera
>> <alvhe...@2ndquadrant.com> wrote:
>>> I think the word "degree" is largely seen as a bad idea: it would become
>>> a somewhat better idea only if we change how it works so that it matches
>>> what other DBMSs do, but you oppose that. Hence my proposal to get rid
>>> of that word in the UI.
>> Well I agree with that up to a point, but I think ALTER TABLE foo SET
>> (parallelism = 4) is not a model of clarity. "parallelism" or
>> "parallel" is not obviously an integer quality. I guess we could
>> s/parallel_degree/parallel_workers/g. I find that terminology less
>> elegant than "parallel degree", but I can live with it.
> Shouldn't it be "max_parallel_workers", at least in some contexts?
> Otherwise, I'd read it as a promise that exactly that many workers
> will be used.
Yeah, I guess it would be parallel_degree -> parallel_workers and
max_parallel_degree -> max_parallel_workers. I still think
max_parallel_workers is confusingly similar to max_worker_processes,
but nothing's going to make everyone completely happy here.
The Enterprise PostgreSQL Company
Sent via pgsql-hackers mailing list (firstname.lastname@example.org)
To make changes to your subscription: