On Mon, Apr 25, 2016 at 2:58 PM, Alvaro Herrera <alvhe...@2ndquadrant.com> wrote: > Tom Lane wrote: >> Magnus Hagander <mag...@hagander.net> writes: >> > On Sun, Apr 24, 2016 at 8:23 PM, Tom Lane <t...@sss.pgh.pa.us> wrote: >> >> FWIW, I agree with Bruce that using "degree" here is a poor choice. >> >> It's an unnecessary dependence on technical terminology that many people >> >> will not be familiar with. >> >> > FWIW, SQL Server calls it "degree of parallelism" as well ( >> > https://technet.microsoft.com/en-us/library/ms188611(v=sql.105).aspx). And >> > their configuration option is "max degree of parallelism": >> > https://technet.microsoft.com/en-us/library/ms181007(v=sql.105).aspx. >> >> Yes, but both they and Oracle appear to consider "degree" to mean the >> total number of processors used, not the number of secondary jobs in >> addition to the main one. The only thing worse than employing obscure >> technical terminology is employing it incorrectly: > > What about calling it something even simpler, such as "max_parallelism"? > This avoids such cargo cult, and there's no implication that it's > per-query.
So what would we call the "parallel_degree" member of the Path data structure, and the "parallel_degree" reloption? I don't think renaming either of those to "parallelism" is going to be an improvement. -- Robert Haas EnterpriseDB: http://www.enterprisedb.com The Enterprise PostgreSQL Company -- Sent via pgsql-hackers mailing list (email@example.com) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers