I noticed that 6943a946c introduces some new functions named delete() and filter(). This does not seem like a terribly bright idea to me. They may not be formally ambiguous with the corresponding keywords, but it's not very hard to imagine how small typos could lead to the parser taking the unintended interpretation and then producing totally confusing error messages. It's even less hard to imagine this choice preventing us from introducing some new syntax in future (for instance, DELETE ... RETURNING ... as a subquery-in-FROM) because it *would* be formally ambiguous.
I think we'd be better off to rename these to tsvector_delete() and tsvector_filter() while we still can. regards, tom lane -- Sent via pgsql-hackers mailing list (email@example.com) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers