On Mon, May 2, 2016 at 1:58 PM, Tom Lane <t...@sss.pgh.pa.us> wrote: > I wrote: >> I think we'd be better off to rename these to tsvector_delete() and >> tsvector_filter() while we still can. > > ... although I now notice that hstore already exposes a function named > delete(), so that ship may have sailed already. But I'm more troubled > by filter() anyhow, since that keyword can appear in expressions --- > it seems much more likely that that would pose a parsing conflict > after future SQL extensions.
But not everybody has hstore installed, so even if that's a problem it won't be a problem for everybody, all the time. +1 for renaming them both. -- Robert Haas EnterpriseDB: http://www.enterprisedb.com The Enterprise PostgreSQL Company -- Sent via pgsql-hackers mailing list (firstname.lastname@example.org) To make changes to your subscription: http://www.postgresql.org/mailpref/pgsql-hackers