On Tuesday, May 31, 2016, Tom Lane <t...@sss.pgh.pa.us> wrote: > I wrote: > > I really think that a GUC named "max_parallel_workers", which in fact > > limits the number of workers and not something else, is the way to go. > > To be concrete, I suggest comparing the attached documentation patch > with Robert's. Which one is more understandable? > > (I have not bothered preparing code changes to go with this, but am > willing to do so.) > > If going this route I'd still rather add the word "assisting" or "additional" directly into the guc name so the need to read the docs to determine inclusive or exclusive of the leader is alleviated.
Robert that it would be confusing but it cannot be worse than this... David J.